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Ok, so if you're reading this you probably connected your original 20GB hdd to your PC, wanting to 
use Xplorer360 to dump data and probably upgrade to a bigger HDD or add remove some data. But 
when you connected your original 20GB HDD back to your xbox .... all of a sudden it doesn't 
recognize the disk. 
 
I got this rude shock when i tried upgrading from my 20GB HDD to a 120GB HDD. I was simply not 
going to accept that my original HDD, that i just read data off, no longer  works on my xbox. I couldn't 
accept how it is possible that some people experience this problem, some don't. There is a tutorial 
floating around on how to fix this with an original Microsoft data migration cable, however I wasn't 
going to shell out more money to fix this problem. If the PC broke it, the PC can fix it. 
  
So here's the answer:  
 
The problem is not Xplorer360, lets get that straight right off the bat. The culprit is your motherboard. 
You see, when you connect your HDD to your PC, your motherboard created a HPA. A HPA is a 
protected area of your HDD that the motherboard or hardware vendor can use to store vital data. 
Some motherboards will do this, some won't, hence why some people experience the problem and 
some don't. This change is enough for your xbox to have a hissy-fit and not want to play nice with the 
hard drive anymore. 
 
You may have tried to connect that broken HDD to another PC, and use Xplorer360 to do a full image 
restore on the disk and still fail. The reason is, even though your 2nd pc may not create the HPA 
automatically, the HPA that was initially on the 1st PC is still active. The HPA affects the LBA size, so 
the XBOX sees a smaller disk than it originally did, hence why it doesn't recognize it. So, to give you 
an example, my Gigabyte motherboard (ICH9R chipset), changed my LBA: from: 39,070,080 to: 
39,067,967 
 
So to change it back i tried using multiple programs to access the HPA and remove it. The problem 
was that once i restarted the computer the HPA came back and my LBA size was once again 
changed. And this is the part i couldn't work out, how to keep the LBA the same, even after restart. 
Then I though of a brilliant idea (brilliant meaning it could potentially damage your motherboard - but it 
just might work) i tried removing the HDD right after the program unlocked the HPA and changed the 
LBA size. And voila !!!! It works !! 
 
So 1 more bit of theory before we get into the tutorial, Why doesn't this affect 120GB disks or larger ? 
The reason is simple. If you bought a 160GB disk like me and flashed it with 120GB HDD ss.bin, you 
have these HPA security sectors on your hard disk, your xbox just doesn't know about them. The HPA 
sectors are created at the end of your hard disk. and since the XBox can only see the first 120GB, it 
doesn't care what's on the 121st GB, 122GB etc etc ...  
 
Here are three step by step tutorials. One for those who used their 20GB hdd's in their laptops or PC's 
thinking they'll never be able to use them in their XBOX 360's again, the second is for people who still 
have all their data on their 20GB hdd just want to get the 360 to identify it and finally the last if for 
those people that created a full drive backup image (which you though stuffed up your drive). 
 
You will need the following tools: 
 
WinHex (registered version) 
MHDD 
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Once you download WinHex, install it, register and get a "Specialist" license. Burn the MHDD iso with 
Nero, ImgBurn, whatever your favorite burning software is. (Alternatively you can get MHDD as an 
exe and put it on your bootable USB stick) 
 
Tutorial 1: Restoring the 20GB HDD to be usable on the 360 from scratch (use this 
tutorial if you used the HDD for something else and you have deleted all the original 
xbox 360 data off it) 
 
1. Connect your original 20GB drive to the PC. 
 
2. Start you PC up and open WinHex 
 
3. Select: Tools -> Open Disk (or press F9) 
 
4. Select your HDD from the List under "Physical Media" 
 
5. Select: Options -> Edit Mode (or press F6) 
 
6. Select: In-place Mode (=editable) and press OK 
 
7. At the ATTENTION popup message press OK. 
 
8. Select: Edit -> Fill Disk Sectors (or press CTRL + L) 
 
9. Select radio button: Fill with hex values: 00 and press OK. 
 
10. You now get a popup saying: Please note that the inteigry of the partition(s)/file system(s) on "your 

xbox 360 hdd model here" may be severyly damaged by this operation. Click OK. 
 
11. Sit back this will take about 10 minutes to complete. 
 
12. Once the erasing completes, you will now need either your original HDDSS.BIN which you should 

have made with HDDHackr or download a generic 20GB HDDSS.BIN file appropriate to your HDD. 
I dont think a HDDSS.BIN from a Toshiba / Seagate will work on Fujitsu and vice versa. (I could 
be wrong) 

 
13. Click: File -> Restore Image 
 
14. In the file name box type: *.* and press Enter 
 
15. Now browse to the directory where your HDDSS.BIN file is and select it and press Open 
 
16. You will get a popup image saying: Is this an image with a partition structure. Click: Yes 
 
31. You will get a popup image saying: Cauttion: You are in in-place edit mode. Click: OK 
 
32. In the "Physical Media" section select your XBOX 360 HDD and click OK 
 
33. Set the following options: 
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Write pattern for damaged source sectors (unselected) 
Simulatenous I/O (selected) 
Avoid damaged areas. Skip Range (unselected) 
Start Sector: 16 
Copy Entire Medium (selected) 
Click OK 
 

17. You now get a popup saying: Please note that the inteigry of the partition(s)/file system(s) on "your 
xbox 360 hdd model here" may be severyly damaged by this operation. Click OK. If you get a 
popup saying you're in editmode, just click OK on that too.  

 
18. You get a popup (summary) in the form of a notepad text file, Close it. 
 
19. Exit winhex 
 
20. Restart the PC booting off the MHDD bootable CD or USB stick. (you may need to make changes 

in the BIOS to boot off CD or USB stick) 
 
21. If MHDD doesn't start automatically for you, or you're using a USB Boot disk type: MHDD and 

press enter 
 
22. MHDD will identify hard drives connected to your PC. for example, for me it identified: 

 
   3) FUJITSU MHV2020BH 0093002C NWxxxxxxxxxx 39,067,967 
 

26. Enter the number corresponding to your xbox 360 HDD and press Enter. (in my case number 3) 
 
27. You will now get to a blue prompt: MHDD> Type: NHPA (and press Enter) 
 
28. Do you want to set Native LBA address (y/N)? - type: Y  
 
29. Native Maximum LBA address: 39070079 Continue (y/N)? - type Y  
 
30. You will get the following message: 
 

Fail. Try to re-power HDD. 
Done. 

 
31. Unplug the power cable from your xbox 360 hdd 
 
32. wait 10 seconds 
 
33. Plug the power cable back in. 
 
34. Type NHPA (and press Enter) 
 
35. Do you want to set Native LBA address (y/N)? - type: Y 
 
36. You will get the following message: 
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Working ... 
Done. 

 
37. Now unplug your power and data cables from your xbox 360 HDD (in that order: first power cable, 

then data cable) and connect the HDD to your xbox 360. 
 
38. Go to the system Settings tab -> Memory 
 
39. In storage devices you should now see an "Unformatted" hard disk. Select it and press A 
 
40. Select format option and press A 
 
41. This will delete all content on this device. Do you want to continue ? Select Yes and press A / OK 
 
42. Enter your console serial number (can be found in the System Info tab in System Settings) 
 
43. Your drive is now formatted and you should see a Hard Drive with 13.9 GB free space  
 
 
Tutorial 2: Removing the HPA without altering data (use this tutorial if your data is still 
intact however your 360 doesn't see the disk) 
 
1. Connect your original 20GB drive to the PC. 
 
2. Start your PC up and in your BIOS make sure you select boot from CD first. 
 
3. Restart the PC booting off the MHDD bootable CD. 
 
4. If MHDD doesn't start automatically for you, or you're using a USB Boot disk type: MHDD and 

press enter 
 
5. MHDD will identify hard drives connected to your PC. for example, for me it identified: 
 

3. FUJITSU MHV2020BH 0093002C NWxxxxxxxxxx 39,067,967 
 

6. Enter the number corresponding to your xbox 360 HDD and press Enter. (in my case number 3) 
 
7. You will now get to a blue prompt: MHDD> Type: NHPA (and press Enter) 
 
8. Do you want to set Native LBA address (y/N)? - type: Y 
 
9. Native Maximum LBA address: 39070079 Continue (y/N)? - type Y  
 
10. You will get the following message: 
 

Fail. Try to re-power HDD. 
Done. 

 
11. Unplug the power cable from your xbox 360 hdd 
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12. wait 10 seconds 
 
13. Plug the power cable back in. 
 
14. Type NHPA (and press Enter) 
 
15. Do you want to set Native LBA address (y/N)? - type: Y 
 
16. You will get the following message: 

 
Working ... 
Done. 
 

17. Now unplug your power and data cables from your xbox 360 HDD (in that order: first power cable, 
then data cable) and connect the HDD to your xbox 360. 

 
Tutorial 3: Restoring the 20GB HDD from an Xplorer360 backup image (if you made 
one using Xplorer360) 
 
1. Connect your original 20GB drive to the PC and load windows. 
 
2. Open up WinHex 
 
3. Select: File -> Restore Image 
 
4. In the filename box type *.* and press Enter 
 
5. Now browse to the directory where you have your "XboxBackup.bin" file which is your Xplorer360 

Backup Image. 
 
6. Select the bin file. By default its "XboxBackup.bin" and click Open. 
 
7. You will get a popup image saying: Is this an image with a partition structure. Click: Yes 
 
8. Select your Target Disk under the section "Physical Media", make sure this is your 20GB xbox 360 

hdd. 
 
9. Set the following options: 
 

Write pattern for damaged source sectors (unselected) 
Simulatenous I/O (selected) 
Avoid damaged areas. Skip Range (unselected) 
Start Sector: 0 
Copy Entire Medium (selected) 
 

10. Click OK. 
 
11. You now get a popup saying: Please note that the inteigry of the partition(s)/file system(s) on "your 

xbox 360 hdd model here" may be severyly damaged by this operation. Click OK. 
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12. You get a second popup saying: No backup is made of the sectors you are about to overwrite 

because of the specified undo limit of 20 MB. Click Ok. 
 
13. Now wait, this process should take about 30 - 40 mins or so. 
 
14. You now get the popup: 39.067,967 sector(s) successfully copied. Click OK. 
 
15. Close WinHex 
 
16. Put in the MHDD CD you burnt prior to starting this tutorial. 
 
17. Restart the PC booting off that CD (you may need to change your settings in your BiOS) 
 
18. If MHDD doesn't start automatically for you, or you're using a USB Boot disk type: MHDD and press 

enter 
 
19. MHDD will identify hard drives connected to your PC. for example, for me it identified: 
 

3. FUJITSU MHV2020BH 0093002C NWxxxxxxxxxx 39,067,967 
 

20. Enter the number corresponding to your xbox 360 HDD and press Enter. (in my case number 3) 
 
21. You will now get to a blue prompt: MHDD> Type: NHPA (and press Enter) 
 
22. Do you want to set Native LBA address (y/N)? - type: Y  
 
23. Native Maximum LBA address: 39070079 Continue (y/N)? - type Y  
 
24. You will get the following message: 
 

Fail. Try to re-power HDD. 
Done. 

 
25. Unplug the power cable from your xbox 360 hdd 
 
26. wait 10 seconds 
 
27. Plug the power cable back in. 
 
28. Type NHPA (and press Enter) 
 
29. Do you want to set Native LBA address (y/N)? - type: Y 
 
30. You will get the following message: 

 
Working ... 
Done. 
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31. Now unplug your power and data cables from your xbox 360 HDD (in that order: first power cable, 
then data cable) and connect the HDD to your xbox 360. 

 
32. Enjoy  
 


